I’ve been using Feeder for awhile now, and have kind of dealt with it skipping around, but it’s still bothering me and I’m not sure if it may be something I’m doing wrong.

I’ve set it so I’m manually syncing my feeds instead of having it do so at regular intervals, in case that may have been the cause.

I’m not holding my phone in a way that I may be touching the sides of the screen and causing it to misread input (so far as I can tell).

I’ve tried returning to the feed both via the app’s back button and the system back button, with both returning me to a different position in the feed (either up to new articles or down to older ones).

  • @stepanzak@iusearchlinux.fyi
    link
    fedilink
    English
    43 months ago

    I’m not exactly sure from where are you returning to the feed. Could you please write the exact steps of what you do, what happens and what do you expect? I’m using feeder too and also has some issues with it. The exact steps are also great if you wanna fill an issue.

    • @ALostInquirerOP
      link
      English
      3
      edit-2
      3 months ago

      Yeah, let me try to break it down better:

      1. Browsing All Feeds.
      2. Tap article headline to view/read article, set to use Feeder’s built-in reader.
      3. Try to fetch full article, if successful, proceed to read to end.
      4. Tap system back button (or app’s back button).
      5. Sometimes it scrolls either up or down in All Feeds to newer/older articles (I think typically down, I’ve not tracked it carefully enough to say for sure).
      6. Expected behavior: return to All Feeds in-place viewing the article headline I tapped into and read, changed from unread to read (unbolded).

      I think I’ve observed this issue more often after recently syncing All Feeds and trying to scroll through them without closing and reopening the app.

      • @stepanzak@iusearchlinux.fyi
        link
        fedilink
        English
        23 months ago

        Thank you. I could figure it out because I use the webview instead of the internal reader. I just set it to the reader and tried multiple articles, but wasn’t able to reproduce the bug you are describing. In your place, I would export the feeds, reinstall the app and import them back.

  • @sodalite@slrpnk.net
    link
    fedilink
    English
    33 months ago

    I’ve been using Feeder a couple months now and haven’t had any issues with it, but I’ve had it set to refresh feeds manually upon opening app since the beginning. What do you mean by skipping around?