• @Sam@sh.itjust.works
    link
    fedilink
    8411 months ago

    When I’m doing coding interviews I always like to start off and say I’m a big fan of very long variable names. “As descriptive as you can be” I say. Then I get to my first for loop. Instead of i I use “iterator” and then when I start a nested loop I use “jiterator” and it always gets a laugh.

    • Dandroid
      link
      fedilink
      2111 months ago

      I used to conduct coding interviews at my old job. If someone came in and had some humor like that, it would be big bonus points in my book. Being someone I would like to be on a team with is very important. Plus, I think it shows confidence and being comfortable in situations that make most people nervous.

      • @Hazama@lemmy.world
        link
        fedilink
        1611 months ago

        I’ve been at two start ups and they had me interview people. Honestly this is what I looked for. I’d ask basic questions to prove you had an idea about coding, but I can teach someone to code, I can’t teach someone to be someone I like working with.

        • KairuByte
          link
          fedilink
          1311 months ago

          You can teach them to code if there is an underlying level of logic to build off. I’ve met a few people in life who I know for a fact will never code, no matter how smart they generally are.

      • @Sam@sh.itjust.works
        link
        fedilink
        511 months ago

        And even if it didn’t help my chances directly like that, even getting a small chuckle would help me be more comfortable and confident.

      • DreamButt
        link
        fedilink
        411 months ago

        Honestly finding someone who can relax and intergrate into your team culture is arguably more important that anything

  • @Poob@lemmy.ca
    link
    fedilink
    57
    edit-2
    11 months ago

    i is for index. j is simply the next letter and we’re too lazy to think up something meaningful

  • @barsoap
    link
    32
    edit-2
    11 months ago

    It depends. x and y are either elements or coordinates, a and b usually elements though in e.g. Haskell reserved (by convention) for type variables.

    The i j k l series is reserved for indices. n m etc. are the counts of something, as such you’ll see i counting up to n. Both are due to mathematical sum notation and general mathematical convention. Random google result:

    Let x1, x2, x3, …xn denote a set of n numbers. x1 is the first number in the set. xi represents the ith number in the set.

    …if you’re using a language in which you use i often chances are you should stop coding in C and get yourself a language with iterators. Manual loops are a bug magnet.

  • @StudioLE@programming.dev
    link
    fedilink
    3011 months ago

    A useful tip I picked up was to use ii instead of j for an inner loop. It’s far more distinct than j.

    If for some terrible reason you have even more inner loops you can easily continue the trend i, ii, iii, iiii, iiiii - or iv, v if you’re feeling roman

    • @hstde@lemmy.fmhy.ml
      link
      fedilink
      3511 months ago

      If you have the need to nest 5 levels of for-loops, I suggest taking a step back and rethinking your approach, my friend.

      Even if that other approach is just refactoring it into separate methods.

    • exu
      link
      fedilink
      211 months ago

      Two or three "i"s is readable, but any more and you’re counting.
      I’Ve started using i, k, m, n that’s usually enough.

    • @Gork@beehaw.org
      link
      fedilink
      111 months ago

      At this point we might as well go full Roman as you suggested. MXMCIIV to MXMCCVII as indices.

    • @barsoap
      link
      110 months ago

      When you have multiple indices you’re also bound to have multiple cardinals those indices count up to, say foo.length and bar.length, so foo_i and bar_i are perfectly legible and self-documenting. A bit Hungarian but Hungarian is good in small amounts. Unless you’re dealing with width and height in which case it’s x and y but it’s not that width_i would be incomprehensible.

  • @dark_stang@beehaw.org
    link
    fedilink
    2911 months ago

    x is used for map, filter, etc. a and b are used for sorts, comparisons and merges. y might be used if I’m doing multiple lambda expressions (but that means I’m in a bad place already). I have no idea why, but these are firm rules in my brain.

    • @DogMuffins@discuss.tchncs.de
      link
      fedilink
      1211 months ago

      I’ve gotten used to using the singular form as in…

      records.filter((record) => …)

      Not saying this way is better but it works for me.

    • russ
      link
      fedilink
      111 months ago

      Yes! I love using x (and xs) for functions over whatever the thing is (or things are).

  • @Cowabunghole@lemmy.ml
    link
    fedilink
    1711 months ago

    It’s my understanding that i,j are conventionally used in mathematics which carried over into programming, but specifically it comes from Fortran in which all integer variables start with “I” through “N” based on said mathematical convention

    • @LuckyFeathers@lemmy.world
      link
      fedilink
      611 months ago

      Yep, this is the answer. In Fortran, all variables are assumed to be floats, unless the variable starts with I, J, K, L, M or N. I’m sure they had a good reason, but it sounds so bizarre today!

    • @galilette@mander.xyz
      link
      fedilink
      1
      edit-2
      10 months ago

      In fact this goes all the way back to Hamilton when he invented quaternion, in which i,j,k are used as basis vectors (which are generalizations of the imaginary i). Later Gibbs dropped the scalar component and gave us the modern vector.

  • TheWoozy
    link
    fedilink
    1511 months ago

    In old FORTAN variable starting with I…N are integers. This is how the practice began.

    • @pazukaza@lemmy.ml
      link
      fedilink
      111 months ago

      Oh wow, I thought it was because “i” was a short way of writing “index”. Then “j” was just logical after that.

      • TheWoozy
        link
        fedilink
        110 months ago

        You are still correct! The letters I & n are the first letters on Index.

  • @throwsbooks@lemmy.world
    link
    fedilink
    1411 months ago

    I always thought i for index when iterating through an array. Then you can’t use i again in a nested loop so j follows.

    Tho sometimes x, y if the array represents coordinates.

    Only a maniac would use a, b.

    • @rarkgrames@lemmy.world
      link
      fedilink
      211 months ago

      One of the very first lines of code I ever wrote was:

      10 FOR a = 1 TO 70

      In Spectrum Basic. I do tend to use I these days, I’ve calmed down since my childhood days 😀

  • @Luvon@beehaw.org
    link
    fedilink
    14
    edit-2
    11 months ago

    I generally use a for each type loop or a map because I am usually applying some function across a collection, and in both cases I use the singular name from the collections plural.

    ’Cities.map(city -> …)’

    For (val city in cities)

    If I actually need the index for some reason I still prefer loop structures that give me the index and the item together

    *note syntax pulled out of my head and not necessarily belonging to any specific language.

    For ( city, index in cities)

    cities.map((city, index) -> … )

    If I need to double loop a matrix array I would use rowIndex and ColIndex for the indexes.

  • Spzi
    link
    English
    1111 months ago

    I find it hard to read when these are together:

    • i, j, l
    • n, m, u, v, w

    From all the possible character combinations, somehow the lookalike combinations are among the most popular. Yes, probably comes from math. I hated it even more when my math prof’s i and j on the board were indistinguishable.

    • @spauldo@lemmy.ml
      link
      fedilink
      English
      211 months ago

      When the practice started, most (if not all) programming languages used capital letters. IIRC the computers that ran early FORTRAN (which is where the I,J,K, etc. convention comes from) didn’t even support lower case letters.

  • @kionay@lemmy.world
    link
    fedilink
    911 months ago

    I prefer index variable names that are two words. The second word is always ‘index’ and the first word describes the enumerable objects. carIndex, productIndex, thingIndex

    I’m not paid by the character count. Longer and more descriptive is better. Long lines that go past your 1080p monitor are probably not long because of variable names but because you insist on doing many things in one line (quit doin’ that). For small functions this isn’t necessary, but too often I’m shunted to the middle of a big function with two or three indecies doing acrobatics over one another and while working on it I have to constantly remind myself that this i and j mean particular things.

    • @GhostlyPixel@lemmy.world
      link
      fedilink
      4
      edit-2
      11 months ago

      I have had too many times where I have been confused trying to figure out a giant nested loop because the writer used i/j/k or x/y/z. It’s even worse when they confused when a particular bug is because they confused what their single letter variables were and used j somewhere instead of i and no one caught it because it is so easy to brush over. Name your stuff what it is, make your life easier, make others lives easier.

  • @atimholt@lemmy.world
    link
    fedilink
    711 months ago

    I like range-based for loops. You can just name the iterator after the object that it actually is. Have to be a little careful though, if the container is named a plural noun, and the natural name is the same word minus the easy-to-miss ‘s’.

    • hh93
      link
      1111 months ago

      If i is lowercase too then it doesn’t make a difference

      But tbh if your function is having mit than 3 levels of nested loops you should probably rethink that function

    • @soloner@lemmy.world
      link
      fedilink
      711 months ago

      I is short for “index” for a traditional for loop for mapping over an array and looking up by index. J comes after I and is used for nested loops so it doesn’t shadow the outer I.

      • @mlc894
        link
        011 months ago

        Is it for “index” or “iterator”?

        • @soloner@lemmy.world
          link
          fedilink
          111 months ago

          I believe index for the classical need to iterate through an array. E.g.

          for (i = 0; I <= arr.length; i++) { var thing = arr[i] … }

          So to me it stands for “index” for array lookup.

          Before map and iterators were implemented in a lot of languages, this was the defacto way to iterate a list. At least this is how I learned it in java/c back in the day. Nowadays I think most OOP languages including java have implemented the “for … in …” Syntax or similar which deprecates this convention.